Table of Contents

Federal/State Tax Planner

John Logue Updated by John Logue

The Federal/State Tax Planner is included in TaxTools, Small Business Tools, and Financial Planning Tools. It allows the user to calculate federal and state income taxes for up to five years or five scenarios.

Opening the Tax Planner

To open the Tax Planner, first select a client in the Client List, then either double-click on Federal/State Tax Planner in the Module Library, or select it and click the Load Module button:

The Tax Planner will open with client data from the selected client mapped in:

Setting Up the Tax Planner

Setup Screen

This Setup Screen is where you set up the the following parameters:

  • Active State (state for current calculations),
  • Default State,
  • Number of Projection Years (or Scenarios),
  • Start Year,
  • Inflation Factors, and
  • Print Options.

To access the Setup Screen, click Setup on the toolbar:

In the below illustration, the Tax Planner has been set up for a two-year projection, beginning with 2019:

When you've finished with the Setup screen, click Summary to return to the Summary screen:

Here's the resulting Summary screen:

Here's the Summary screen for a three-scenario setup:

If you click the Save Default button after changing the settings in the Setup screen, the settings will be used for subsequent tax plans. Otherwise, the settings will apply to only this plan.

Top-of-Page Fields

Fields can optionally be displayed at the top of each page, allowing you to view some calculation results without having to return to the Summary screen. This feature is controlled by options on the Tools menu:

  1. Fields to Display on Each Page displays a menu of fields which can be selected for display when the feature is turned on. (The menu can also be accessed by pressing Ctrl+F.)
  2. Toggle Display of Fields on Each Page allows you to turn the feature on and off. (This can also be done by pressing Ctrl+D.)

In the illustration below, the ADJUSTED GROSS INCOME, TAXABLE INCOME, FEDERAL TAX, and FEDERAL REFUND (-)/BALANCE DUE fields have been selected from the menu (left), and are therefore displayed at the top of each page (right):

Screens and Data Entry

Summary Screen

The Summary Screen is the first thing you see when you open the Tax Planner:

Some data is entered on this screen, but most will be entered on Detail screens, which will be discussed next.

Note the blue, green, yellow, and gray fields:

  • Blue fields are for user data input;
  • Green fields display calculation results;
  • The yellow field is the active field (the one your cursor is currently in);
  • Gray fields are not accessible.
Green fields marked with an asterisk (*) have associated Detail Screens, into which data is entered to achieve the calculated result. To access the detail screen for a calculated field, either double-click on the field or press Alt-D when the field is active. You can also cycle through the detail screens by using the PgUp and PgDn keys. (See Detail Screens, next.)

Access help by pressing the F1 key:

Access help for a specific field by pressing F2 when your cursor is in the field. For example, here's the help for the Filing Status field:

Field help can also optionally be displayed in a yellow Help Panel at the bottom of the screen:

Detail Screens

In addition to the Summary Screen, there are seven Detail Screens where data is entered for calculated fields. To access the detail screen for a field, either double-click on the field or press Alt-D when the field is active. You can also cycle through the detail screens by using the PgUp and PgDn keys.

For example, double-clicking in the Wages field on the Summary Screen takes you to the Wages detail screen:

From there, pressing the PgDn key will take you to the Income - 1 detail screen...

...and so on.

Some Detail Screens have additional Detail Screens within them. For example, several fields on the Other Income (Income - 2) detail screen are marked with an asterisk, indicting that they have their own detail screens:

Double-clicking in one of these fields opens its detail screen, such as this one for the 199A Pass-through Deduction:

To return to the Income - 2 screen, click the Back button on the toolbar:

Copying from Column to Column

If you are using multiple columns, there a several options available from the Tools menu that will allow you to copy data from column to column:

  1. Repeat As Is copies the amount in the current field (field the cursor is in) into all columns to the right. (This can also be done by pressing CTRL+R.)
  2. Inflated Repeat inflates and copies the amount in the current field into all columns to the right, using the inflation factor entered on the Setup screen. (This can also be done by pressing CTRL+I.)
  3. Repeat Entire Column As Is copies all amounts in the current column (column the cursor is in) into all columns to the right.
  4. Repeat Entire Column Inflated inflates and copies all amounts in the current column to all columns to the right, using inflation factors entered on the Setup screen
  5. Copy Column to Another Column copies the current column to any other column.

Charts

The Charts feature, accessed from the Tools menu, allows you to plot various tax results against variable income fields. You can also use it to compare taxes in different states. Click Charts... on the Tools menu to view the Chart Options screen:

Variable Field

First, choose a Variable Field from the dropdown menu, and Start, End, and Increment values to determine the scale for the Variable Field:

Options

Next, choose one of the three options available:

Select up to five Fields to plot using Tax Planner data in the Column selected

This option allows you to plot five different result fields as the Variable Field changes. Select the desired fields from the dropdown lists next to the labels Field 1, Field 2, etc. If the Tax Planner is currently displaying more than one column (projections or scenarios), you must specify the column to plot using the column selector at the top of the screen.

Plot Field 1 for each scenario or projection in the Tax Planner

If the Tax Planner is currently displaying more than one column, this option will increment the variable field in each column and plot it against the result field specified next to Field 1. This can be used to plot the tax for up to 5 scenarios as the Wages increase, for example.

Plot Field 1 for each of the STATES selected in the List

This option allows you to compare the state tax for different states as Wages increase. Check the desired states to compare from the list and select the result field next to Field 1. This should be a state field, typically State Refund/Balance Due, since you are comparing state results. If the Tax Planner is currently displaying more than one column (projections or scenarios), , you must specify the column to plot using the column selector at the top of the screen.

Selecting too many states may make it difficult to tell states apart on the chart.

Alternate Legend / Title

By default, the program uses the Variable Field name and the Result Field name to create a default title and legend label for the chart. However, you can enter your own text to use as the title and legend labels, if desired.

Viewing / Printing Chart

After setting the parameters, click the Chart button to view the resulting chart:

To print the resulting chart, click the Print button in the lower left corner of the chart:

A number of print options are available from the File menu:

  1. Print As Marked in Setup prints according to the options you chose on the Setup Screen.
  2. Print Current Screen prints only the current screen.
  3. Print Worksheets allows you to select worksheets to be printed from a sub-menu.
  4. Preview Worksheets allows you to preview worksheets onscreen before printing.
  5. Print Field Details allows you to print detail screens.

This concludes the tutorial. For more information, please see the module Help file.

How did we do?

CFS Program Interface

Quick Reference Guide

Contact