Table of Contents

CFS Program Interface

John Logue Updated by John Logue

Most CFS programs share a similar program interface. The following examples use TaxTools. Other programs will vary slightly.

Three Panes

Most CFS programs feature a main screen divided into three window panes:

  1. The Client List is for managing client data,
  2. The Client Folder is for managing client files, and
  3. The Module Library lists the modules (forms, worksheets, flowcharts, etc.) available in the program.

1. Client List

The top-left pane is the Client List, the repository for all of your client data. The number in parentheses below the words "Client List" indicates the number of clients in the list. Buttons to the right allow you to Add, Edit, or Delete clients from the list.

Client Profile Screen

Clicking on the Add or Edit buttons, or double-clicking a client's name in the list, opens the Client Profile screen, where the client's information is entered:

Deleting Clients

If you click Delete Client while a client is selected, you will be asked if you want the client to be MARKED for deletion. The client can still be recovered unless you later PURGE DELETED CLIENTS.

Quick Access

The first item in the Client List, "--- <Quick Access> --- No Client ---," can be used if you wish to open a module without associating it with a client:

There are disadvantages to using Quick Access: client data must be entered manually, and the file is not saved in a client folder, making it more difficult to find it later.

2. Client Folder

The top-right pane displays the Client Folder for the currently-selected client. If module data has been saved for the client, it will be located in a "folder" with the name of the module:

Click on a folder to open it and view the saved file descriptions:

Double-click on a file to open it, or click Open File with the file selected. Click Delete File to delete a saved file.

3. Module Library

The bottom window, the Module Library, displays a list of available modules—forms, worksheets, flowcharts, etc.—in the program:

The number in parentheses below the words "Module Library" indicates the number of modules in the list (in the above illustration, 342). The list can be refined by the use of the Type and Category dropdown menus, making it easier to find the module you are looking for.

Type

The Type dropdown menu allows you to filter the Module Library according to type. You can choose to display Flowcharts, Tax Forms, Worksheets, PDF Documents, or All Types:

Category

The Category dropdown menu allows you to filter the Module Library by category, including Financial Calculators, Payroll/Income, Retirement, Updated or Revised, state, etc.

Favorites

For convenience, you can create a custom "Favorites" list of modules, accessed by the Favorites button on the Module Library toolbar or by selecting "Favorites" from the Category dropdown menu:

Add selected (highlighted) modules to the list by clicking the Favorites button, then selecting Add to Favorites from the menu:

To remove a selected (highlighted) module from the Favorites list, select Remove from Favorites from the menu:

If your Favorites list is long, you can filter it by selecting Filter by Type:

Find Module

The quickest way to locate a module is by using Find Module, which can be accessed from the File menu or by using the Find Module button:

Enter a keyword (or string) and click OK; the category will change to "Find Module Results," and all matching entries in the Module Library will be displayed.

To return to the "All" category with the current module selected, press CTRL+F3. Press CTRL+F3 again to repeat the last "Find Module" operation.

Loading a Module

To load a module, either double-click on it or select it and click the Load Module button. The client information for the client that was selected in the Client List will be mapped into the module:

Alternatively, if Quick Access was selected, all of the fields will be empty:

Main Screen Menus

File

Several print options are available from the File menu, as well as the Find Module dialog, discussed above. The File menu also has the following options:

Editor...

The editor can be used to create, edit, and save custom letters and documents. It has full text formatting capabilities. Documents may be saved in Word format (doc), rich-text-format (rtf), ASCII text (txt) or editor format (txm).

Preparer/Rep Database...

Use this option to access the Preparer/Rep database. Once preparer/rep data has been entered into the database, it can be used to autofill forms calling for this information.

Labels/Envelopes...

This option opens a Label/Envelope Maker that will print four-line mailing addresses on labels, envelopes, or slipsheets.

Display Calendar

A simple monthly calendar can be displayed by selecting Display Calendar. To close the calendar select Hide Calendar or click the X in the corner of the note window.

Firm Information...

This option opens the Firm/License Information Screen, where your Firm Information and License Code are entered. This screen is displayed when the program is first run, and can also be accessed from the About screen. Your Firm Information can optionally be printed on most worksheets.

e-Mail Current Client...

This option opens your default email program with the currently selected client's email address filled in.

Recently Saved Modules

The bottom of the File menu has a list of recently saved clients and modules, providing a quick way to return to something that was recently saved.

Utilities

The Utilities Menu includes the following options:

Backup/Restore Data

The Backup and Restore utilities allow you to back up and restore your data. (For more information, see How do I back up/restore my data?)

Import Utilities

Several import utilities allow you to import data from CFS software for the current and previous years, as well as from other software.

Export Client List

This option allows you to export client data in a comma- or tab-delimited file. You can specify which client fields to include in the file and the order in which they will appear, then export all or selected clients.

Find Client...

Opens a dialog to allow you to search for a client:

Find Clients with Current Module

Opens a dialog to allow you to find clients with the currently highlighted module:

Filter/Sort Client List...

Opens a dialog to allow you to filter and sort your client list:

Set Client Codes...

This option allows you to assign a two-character code to selected clients. Client codes can help you organize your clients, allowing you to sort or filter them based on the code.

Purge Deleted Clients

Use this option to permanently remove clients that have been "marked for deletion." After this option is used, deleted clients cannot be undeleted.

If the program has multiple users, this feature should only be used when no one else is using the program.
Undelete Clients

This option allows you to restore deleted clients, providing they have not been purged.

Repair Client Database

If the client database has been corrupted—i.e., if the program cannot read or open it—this option may be able to repair it.

Network Utilities

If you have the network version of the program, two network utilities are available from the Utilities menu:

  1. Remove All Client Locks can be used to unlock all clients that were inadvertently left locked by another user. (This utility should be used only after all other users have exited from the program.)
  2. The User List option opens the User List screen, allowing you to Add, Edit, or Delete users, or log on as a different user.

Configuration

The Configuration item on the menu bar does not open a menu. It opens the Configuration Options screen:

The Configuration Options screen is where you can set options for automatic update, printing, database location, automatic backup, and display. If you make changes to any settings, be sure to click Save Settings to save them.

Internet Options

The Internet Options menu has the following options:

Update from the Web

Checks the internet for a program update and reports back. If an update is available, it can be downloaded and installed automatically.

This feature requires that the user be connected to the internet.
CFS on the Web: www.taxtools.com

This option opens your web browser to the CFS website's homepage.

Go to MyCFS Account

This option opens your web browser to your MyCFS account. (For more information, see Why do I need a MyCFS account?)

Download IRS Fill-in Forms/Pubs...

This option takes you to a list of current PDF forms and publications available from the IRS website, which you can download into the program.

CFS Tech Support Request...

This option opens your browser to a Technical Support Request form on the CFS website. Fill it out and submit it, and a member of the CFS technical support staff will contact you regarding your issue.

Help

The Help menu has the following options:

Contents

This option opens the Table of Contents for the program’s Help file.

Search for Help On…

This option opens the Index for the program’s Help file, where you can enter keywords to find help topics.

Using Help

This option gives you an overview of the program's Help system.

Tips and Tricks

This option opens a list of tips that can help you get the most out of the program.

What's New

This option opens a list of the latest program features.

View Reminders...

The program displays a Reminder screen when you open it, with timely information. If you need to view one of them again, this option will open the Reminder screen.

Instructional Videos on the Web

This option opens your browser to the Instructional Videos page on the CFS website. The page has links to short, silent videos demonstrating how to perform specific tasks or use the programs efficiently.

About

This option displays the program's About screen, where you can find the program version number. You can also access the License Agreement (EULA) and Firm/License Information screen from here.

Module Menus

Each module has its own menus. Options may vary depending on the module, but some options are common to all module menus.

File

Module File menus include the following options:

Save As

Use this option to save a file without overwriting the current file. The Save to Client dialog will display the default file description, which can be changed. In the box at the bottom, there will be a list of any files currently saved with New File at the top of the list. If nothing is selected then the file will be saved as a new file. If you want to overwrite a saved file, select it in the list and click OK. You will be prompted that you are overwriting a saved file.

Change File Description

Use this option to change the description displayed in the Client Folder for the current file.

Client Database

Use this option to open the client database (or use the F3 hotkey).

Preparer/Rep Database

Use this option to open the preparer database (or use the F4 hotkey).

Options

Module Options menus have several display options, including:

Change Field Format

This option can be used to unformat the active field and/or change the number of characters allowed. The character length change is temporary and not saved with the module, so loading a saved file and accessing the field may cause the extra characters to be lost.

If the active field is a tax ID field, the option can be used to select ITIN, SSN, SSN (masked), or "APPLIED FOR."

Map Client

Use this option to map in new client data after selecting a different client from the client dopdown list below the menu bar. The.option can also be used to select between client and spouse data.

Help

In addition to the usual Help menu options, the module Help menu has the following options:

Instructions/Module Overview

This option opens the module Help topic or, in the case of tax forms, form instructions. It can also be accessed using the F1 hotkey.

Field Help

This option provides help for the active field, which can also be accessed by using the F2 hotkey and is optionally displayed in a yellow help panel at the bottom of the screen.

How did we do?

Federal/State Tax Planner

Contact