Error 12007 "Name not resolved" on Update from the Web

This error generally occurs at program start, but it can also occur when you select "Update from the Web" from the "Internet Options" menu.

Cause

The error indicates that the program has attempted to access the CFS website (www.taxtools.com). When the program tries to access www.taxtools.com, a query is sent to the domain name server (DNS) via the Internet, asking for the IP address for that name. (The DNS is the white-pages directory of the Internet.)  Error 12007 ("Name not resolved") means that there was no reply from the DNS. Try to access the Internet using your web browser (Internet Explorer, Firefox, or other). If you can't, the problem is not with the CFS program.

If your browser can reach the Internet but the CFS program can't, the CFS program is being denied access by a firewall program. This usually happens after the program has been updated. The first time the program tries to access the Internet after the update, the firewall program recognizes that there is something different, and it opens a dialog box telling you that the program is attempting to access the Internet.  If you click the OK button (or hit ENTER on the keyboard) instead of clicking the ALLOW button, the firewall program makes a DENY entry in its table.

Solution

The solution is to determine which firewall program has an entry in its program table with the switch (checkbox) set to "deny" instead of "allow," and to change the entry.

Examples of firewall programs include Windows Firewall, Symantec, McAfee, and Bit Defender. To find the program table, look under "Firewall Configuration," "Firewall Settings," or "Firewall Rules."

If you are unable to find the firewall program or entry, configure the CFS program to stay off the Internet until you are able to fix the firewall settings. Open the "Configuration" dialog, and clear the check box next to "Check for web updates when program starts."

In the meantime, you can update the program manually. (See How do I manually download and install an update?)

How did we do?

Error 105: The transmission was unsuccessful

Error 12029 "Cannot Connect" on Update from the Web

Contact