Error 3045 in Payroll System

"Couldn't use; file already in use."

This database access error can occur in CFS Payroll System and is generally intermittent. The program may fail on one workstation, while other workstations are able to use the database. Or the problem may be encountered once, while later access to the database is successful.

Cause

It is likely that the problem is caused by a conflict with other software or processes during access to the database file. A single "access" to the database may consist of 20-30 physical operations. We have identified three possible conflicts that may cause Error 3045:

  1. Antivirus support,
  2. Automatic backup system,
  3. Simultaneous data import from multiple workstations.

Solutions

Below are solutions for each of the three conflicts.

1.  Antivirus support

If you are running antivirus software, you can test to determine whether it is causing the problem. Antivirus software has different components. One of the components is called real-time protection. Turn off this part of the antivirus program and then test Payroll System to determine whether it still fails.

If this test indicates that the real-time part of the anti-virus program is the problem, the fix is to configure the antivirus program to make an exception or apply an exclusion for at least the current database folder (e.g., X:\CFSLIB\PR2012\PR2012DB\). To apply to all years, exclude the entire CFSLIB folder (X:\CFSLIB).

Some antivirus programs, such as Avast, require the exclusion of a database on a network drive to be expressed in UNC terms, e.g., \\SERVER\SharePoint\CFSLIB\.
Scheduled antivirus scans can continue to check the folders. It is only the "real-time" or "auto-protect" part of the antivirus program that needs to be limited.

2. Automatic backup system

Some automatic backup utilities immediately back up any file you change, either to an external hard drive or to the internet. Such systems may cause Error 3045. However, it should be possible to configure them so that they do not interfere with Payroll System.

First, configure the automatic backup utility so that it does not back up the Payroll System database folder. Second, make sure Payroll System is configured to create a backup on exit (whenever data has changed). The automatic backup utilility can then capture that backup folder.

The automatic backup utility may perform both real-time and scheduled backups. If so, you can configure it to exclude CFSLIB from real-time backups, while allowing scheduled backups.

If necessary, call the vendor of your automatic backup software, explain to them that there is conflict, and ask them how to avoid it.

3. Simultaneous data import from multiple workstations

Error 3045 may occur when any of Payroll System's "import from other software" utilities are being executed from multiple workstations at the same time. The obvious solution is to either do all of the imports from one workstation or to communicate between users to make sure that only one such import is being performed at a time.

How did we do?

Error 3031 when Restoring Payroll Data

Error 3049 in Payroll System

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