Error 3045 in Payroll System

Toby Baker Updated by Toby Baker

"Couldn't use; file already in use."

This database access error can occur in CFS Payroll System and is generally intermittent. The program may fail on one workstation, while other workstations are able to use the database. Or the problem may be encountered once, while later access to the database is successful.

Cause

It is likely that the problem is caused by a conflict with other software or processes during access to the database file. A single "access" to the database may consist of 20-30 physical operations. We have identified three possible conflicts that may cause Error 3045:

  1. Antivirus support.
  2. Automatic backup system.
  3. Simultaneous data import from multiple workstations.

Solutions

Below are solutions for each of the three conflicts.

1.  Antivirus support

  1. Temporarily disable real-time protection in the antivirus software.
  2. Relaunch Payroll System to see if the error has stopped.
  3. If the test indicates that antivirus was the problem, reconfigure your settings to exclude the CFSLib folder.
Scheduled antivirus scans can continue to check the folders. It is only the "real-time" or "auto-protect" part of the antivirus program that needs to be limited.

2. Automatic backup system

Some automatic backup utilities have been known to cause conflicts. If possible, see Setting Automatic Backups to create a backup folder within Payroll System, and set the automatic backup utility to backup that instead.

3. Simultaneous data import from multiple workstations

Error 3045 may occur if Payroll System's "import from other software" utilities are being executed from multiple workstations. Check to make sure only one import operation is being run at one time.

How did we do?

Error 3031 when Restoring Payroll Data

Error 3049 in Payroll System

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