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Install / Uninstall: Setup Runs Another Vendor's Installer

Christopher H Updated by Christopher H

Problem

Running our software triggers a Microsoft Installer (MSI) window that requests another developers installation software.

Our software either fails to run or runs after a very long delay.

When this problem is encountered MSI will search the computer's file structure for the file that was originally used to install the software. This process can take some time depending on the overall speed of the computer and the number of folders being searched through.

Cause

The most common cause for this is some software has not finished installing or finished being uninstalled completely on the computer.

So when CFS software is run any Windows components that are common between the two software are prevented from being used until the software at issue is installed / uninstalled completely.

For example, you may be trying to run TaxTools but a QuickBooks installer window is displayed instead.

Fix

Allow MSI to complete the install / uninstall.

Solution 01

Typically MSI will mention the name of the software at issue along with any file(s) associated with the software that MSI requires in order to complete its task.

If this is the case, simply provide the location of the file(s) MSI is requesting.

If you don't know the location of the requested file(s) and MSI provides the name of the software, download then rerun the installer for the software from the appropriate manufacturer's website.

If the installer for the software is no longer available try Solution 02 below.

Solution 02

If the name of the software MSI is trying to install / uninstall is known, there is a tool developed by Microsoft that is designed to resolve this kind of problem.

Use the following link for more information and to download Microsoft's The Program Install and Uninstall Troubleshooter tool.

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