Generic ASCII File Client List

Jake Forster Updated by Jake Forster

Import Generic ASCII File Client List/Drake Client List

This utility may be used import client demographic data from a standard text file containing a list of the user's clients. The text file can be a delimited file (typically a CSV file) or a fixed width file. The file can be generated in any fashion but would usually be obtained by exporting the client list from the user's tax preparation software. After creating the file, follow the steps below to import the client information. Drake software users should see the at the end of this help topic to streamline the setup process.

  1. On the main program screen, select the Utilities menu, then Import from Other Tax Software, then Generic ASCII File Client List/Drake Client List. From the file dialog box, select the drive and directory that contains the text file to be imported.
  1. Select the desired import file from the list and then click Open (or just double-click on the file).
  1. In the Generic Import Client List window, select the appropriate Delimited or Fixed Width file type option and Client Type option.

(NOTE: To the left of the import from grid there is a step indicator label that indicates what the next step is). (Step Indicator is at STEP 1 here.)

To load a previously saved all import options (saved in Instructional Step 14) click the LOAD button under All Options

or the LOAD ALL menu item under the File menu and select the desired all options setup from the list, then click the LOAD button. (Selected configurations can also be deleted using the DELETE button.)

  1. If the Delimited option was selected, then select the appropriate delimiter and text qualifier options.
  1. If the Fixed Width option was selected, then select the appropriate type of Fixed Width option: Lines ending with carriage returns or Record length or Number of records. If using the Record length option, set the number of characters per record by entering the correct number of characters in the adjacent combo box . If using the Number of records option, set the number of records in the import file by entering the correct number of records in the adjacent combo box. (If the number of characters per record is not known or if the number of records is not known, select a calculated one from the drop down list). Enter a number between one and fifty into the Minimum number of records for criteria matching text box or just use the default of twenty-five (NOTE: If there are less than fifty records in the import file, this number is not used). The UPDATE GRID button can be used to update the grid if the value in this criteria matching text box is changed from the default twenty-five.
  1. Then click the NEXT button to load the import from grid and setup the import to grid. (Step Indicator changes to STEP 2).
  1. If the first line of the import file contains column field names (such as First Name, Last Name, SSN, etc.), click the check box for that option.
  1. For fixed width files, a column or adjacent columns can first be selected and then by clicking the APPEND COL(S). button, appended to the column to the LEFT in order to combine columns before importing. Clicking the SEPARATE COL(S) button, reverses this operation and breaks the appended columns back into their original columns (only for the most recent append operation).

  1. For fixed width files, a selected column can be split into two columns by placing the mouse pointer over the LEFT column grid line in the header row (the first row) and dragging the column line to the RIGHT the desired number of characters. After releasing the mouse button to complete the drag operation, the column will be split at the new column grid line position into two columns with the new column on the LEFT.

  1. For fixed width files, an alternate method of splitting columns can be done by first selecting and then double-clicking on a cell in the desired column in the import from grid to invoke edit mode. Press the HOME key to make sure the cursor is at leftmost position in the cell, then press the RIGHT arrow key repeatedly to set the position at which the column is to be split, then press ENTER. Next, click the CURSOR SPLIT COLS. button to split the column into two columns with the new column on the LEFT.

  1. For fixed width files, in order to remove undesired information from the import from grid, a row or adjacent rows can first be selected and then deleted by clicking the DEL ROW(S) button.

  1. After all of the import from columns are setup, click once on a column cell in the import from grid (the grid that is closer to the top of the window under the buttons), then click once on a column cell in the import to grid (the grid that is near the bottom of the window) to set the configuration for each import column or type import from grid column numbers (the grid that is closer to the top of the window under the buttons) into the import to grid cells (the grid that is near the bottom of the window).
  1. Then click the NEXT button. (If the minimum number of import columns are setup, the NEXT button changes into the FINISH button and the Step Indicator changes to STEP 3. NOTE: Clients without ID numbers will not be imported.)
  1. To save all import options, click the SAVE button under All Options or the SAVE ALL menu item under the File menu and enter a description in the dialog text box, then click the SAVE button. (Selected configurations can also be deleted using the DELETE button.)
  1. Select the clients you wish to import in the import from grid, then click the FINISH button to import client information into the current database.

This utility imports only the client information such as names and addresses.

 

Drake Tax Preparation Software

Drake software has an export function to create a delimited file containing client demographic data. The Import Generic ASCII File function has an option to specify that the delimited file was exported from Drake software. This option streamlines the setup process for importing the file.

To create the client list file from Drake software, first open the Drake program, then click the Tools menu item near the top of the Drake window. Next, select the File Maintenance menu item in the drop down menu. Then select and click the Export Client/EF Data menu item in the drop down menu to the right. After the Export Client/EF Data window opens, make sure the Export client data files option on the left is selected, then check the Export to CSV (Comma Separated Values) checkbox on the left, then type the path and file name for the Drake Client List CSV import file in the Path\File name for export data textbox below. Next, click the CONTINUE button to create and save the Drake Client List CSV import file. Then click the EXIT button to close the Export Client/EF Data window and exit the Drake program. Next, follow the steps below to import the Drake Client List into the current program.

  1. On the main program screen, select the Utilities menu, then Import from Other Tax Software, then Generic ASCII File Client List/Drake Client List. From the file dialog box, select the drive and directory that contains the text file to be imported.
  2. Select the file to be imported and click Open (or just double-click on the file).
  3. In the Generic Import Client List window, check the Import Drake Client List checkbox and choose Client Type; Individual or Business. The other appropriate options have been selected for you. If the file contains both type of clients, then you will have to repeat this process to import the other client type.
  4. Click the NEXT button to load the client list. The columns assignments for a standard Drake export file have been done for you. (Step Indicator changes to STEP 3).
  5. Select the clients you wish to import in the import from grid, then click the FINISH button to import client information into the current database.

How did we do?

Export Client List

Importing/Exporting Client Data

Contact