Error 3050 "unable to lock" in Payroll System

Toby Baker Updated by Toby Baker

Cause

In Payroll System, a user cannot edit information that is in use by another user to prevent duplication of data. If a user cannot lock a file, it is usually due to incorrect security settings or resource overload on the system.

Security

Each user logon must have modify or change permission on the Properties/Security tab for the database folder. if the database is being accessed across a network, each user must have modify or change permission on the Sharing tab of the share point on the server. If any user without the appropriate permissions attempts to access the database, error 3050 is a likely result.

Resource Overload

In some cases, a system timeout can occur causing the error. The cause may be either antivirus software or automatic backup utilities.

Solution for Antivirus Software

  1. Temporarily disable real-time protection in the antivirus software.
  2. Relaunch Payroll System to see if the error has stopped.
  3. If the test indicates that antivirus was the problem, reconfigure your settings to exclude the CFSLib folder.
Scheduled antivirus scans can continue to check the folders. It is only the "real-time" or "auto-protect" part of the antivirus program that needs to be limited.

Solution for Automatic Backup Software

Some automatic backup utilities have been known to cause conflicts. If possible, see Setting Automatic Backups to create a backup folder within Payroll System, and set the automatic backup utility to backup that instead.

How did we do?

Error 3049 in Payroll System

Error 3051: The Microsoft Jet database engine cannot open the file...

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