Using the Editor

Jake Forster Updated by Jake Forster

Using the Editor

See also Editor for general information.

The editor is a small word processor contained within the program. It serves as a free standing editor for creating documents and as an editor for client documents created from certain modules. The editor can be loaded from the Module Library screen using the File, Editor menu item. This is referred to as the free editor mode. The editor is not associated with a module or the current client. Any document created in the free editor mode may be saved and loaded in the free editor mode only.

Some modules loaded from the Module Library use the editor to display the document for editing before printing. The document was constructed by the module from a template. When these documents are saved they are associated with that module and are displayed in the Client Folder. The program controls the document name but the user can enter a description. Some modules load the template in the editor directly on startup and other go through a setup screen first. Information entered into the setup screen is used to construct the document. In this case the setup screen information is saved separately from the editor document but the editor document is associated with the setup screen file.

If you want to create and save your own documents, load the editor from the File, Editor menu item.

The editor menu is shown above. Below is a description of some of the editor menu items.

File menu

New – Presents a new document. Also see the New toolbar button.

Open – Shows a dialog that the user may choose a file to open. Also see the Open toolbar button.

Save (As) – Saves the document to a file. If it has not been saved then a dialog is shown to allow the user to name the file. This is the same as Save As. Also see the Save toolbar button.

Export As – Same as Save As when in the free editor. When in the editor as part of a module, Save As functions to save the document as a file that the module can reload, whereas, Export As functions to save the file separately. Note that the user may choose to save the file as Text (txt), Rich Text Format (rtf), or Template (txm). Template is the native format for the program. All program templates are saved as txm files.

Customize Template – This should be used in the free editor mode. It is the same in this mode as Open except the file dialog starts in the program’s template directory. The user may load an existing program template, edit the file, and save it again. The module that uses that file will use the edited version as long as you don’t rename it. If you later decide you want the original version back, you must delete the template file and reinstall the program.

Edit menu

This menu contains the standard entries to Cut, Copy, Paste, etc. when editing text. Of interest when the editor has been loaded as a module is the Select Next Field item. Most editor modules have fields that the program fills in either from the client information or from a setup screen. Some documents also have fields which the user is expected to complete before printing. Select Next Field moves to the next field requiring input, if any, and selects the text in the field. The hot key combination for this menu item is <CTRL>+F.

View menu

This menu allows the user to specify which toolbars are visible, if control characters (tabs, spaces, paragraphs) are visible, and what magnification to use.

Insert menu

Text – Allows a text file to be inserted at the cursor.

Table – Creates a table at the cursor. The user can specify the number of rows and columns. Tables can be used to create columns in the document. Tables are created the full width of the document by default but can be resized using the table width markers (thin vertical line) on the tab stop bar directly above the ruler. The table width markers may be dragged left or right by clicking marker and holding down the mouse. Each cell in the table can be formatted separately with borders. See the Format menu below.

Format menu

Character – Allows the user to specify the text formatting (font, size, bold, etc.) Note that the font, size, bold, italics, and underline attributes are also available on the formatting toolbar. Format changes affect the currently selected text and any text entered at that insertion point.

Paragraph – Allows the user to specify the line spacing, alignment (left, center, right) and indentation settings for the paragraph. Note that the alignment setting is also available on the formatting toolbar.

Paragraph Frames – Option to put lines around selected sides of the paragraph.

Table – Allows the user to specify spacing, background shading, and line borders for the selected cells in a table. This can be useful for creating a line of a fixed length.

Document – The document paper size and margins are set here.

The editor toolbars are shown above. Below is a description of the toolbar items from top to bottom, left to right.

General toolbar

Client List – This is a drop-down list of the same clients shown on the main Client List screen. The current client is shown. This list will only be enabled when the editor has been entered directly with a module starts. In this case the user may use the list to change clients and any point. The document will be saved in the client’s directory shown in the list. If the module loads the editor after displaying a setup screen, then the current client will be displayed in the list but cannot be changed from the editor. To change the client the user must return to the setup screen and change clients on that toolbar list. If the editor is entered in free mode then the client list is not used.

New, Open, Save buttons – These buttons perform the same tasks as the corresponding File menu entries.

Cut, Copy, Paste buttons – These buttons perform the same tasks as the corresponding Edit menu entries.

Print, Print Preview buttons – These buttons perform the same tasks as the corresponding File menu entries.

Map Client button – This button is only available for modules that load the editor directly on startup. Normally in this mode the client information is automatically mapped in the document. If the user customizes the document and wishes to save it for more than one client, the user may changes clients using the toolbar client list and then use the Map Client button to map the new client’s information to the customized document before saving.

Magnification drop-down – Same as the Zoom item on the view menu.

Formatting toolbar

Font name list, Font size list, Bold (B), Italic (I), Underline (U) buttons – Same as the Character formatting that can be done from the Format menu.

Alignment buttons (left, center, right, left and right) – Same the paragraph formatting that can be done from the format menu.

Tab buttons (left, right, decimal, center aligned) – Allows the user to set tab stops for the selected lines in the document. The tab stops for the current line are shown directly above the ruler. Each line can have different tab stops. When modifying tab stops, first select all the consecutive lines for which the tab stops are to be effective by highlighting the text. To remove an existing tab stop, click the tab stop symbol above the ruler and drag it completely off the side of the screen. To move a tab stop drag it left or right to the desired location. The location of the tab stop is shown on the left edge of ruler when you click on the tab. To add a tab stop, click on the tab button for the desired alignment and then click on the tab stop bar above the ruler to add the stop.

How did we do?

Repair Client Database

Contact